[Quick Links] |
Search Site

Site Details

rendered in 0.0423 secs

Captain's Log | Thursday 6th of July 2017

Web Server checks after upgrade | update apt-get linode


We have checks for code, here are some for when you've updated the server and want to check all is well.
  1. Snapshot the server
  2. sudo aptitude update
  3. sudo aptitude safe-upgrade (or aptitude full-upgrade, ask in irc)
  4. any other upgrade work
  5. Reboot
  • webmin->Re-Check Configuration
  • load novascore
  • load fghgf
  • send an email from usermin to work
  • reply
  • send an email from phone (important, tests dovcote, which is not usermin) to work

Phone checks after update | modification system app application delete


1. Do what you're doing
2. Reboot
  • Test tethering
  • Test GPS
  • Test front cam
  • Test rear cam
  • call someone for mic and earphone test
  • Test stylus pen write and seating detection
  • Test infra red
  • Test loud speaker
  • Test vol up and down
  • Test power button screen on/off
  • Test physical home button


Captain's Log | Wednesday 5th of July 2017


raspberry pi no HDMI output until rebooted | raspberrypi input sleep src
Add into /boot/config.txt this line:
hdmi_force_hotplug=1

when running a cronjob, the output redirect to a logfile is creating a blank file | empty


throw 2>&1 on the end, for example:
0,10,21,30,40,50 * * * * /home/login/trace_sjfhs.sh >> /home/login/traceroute.log 2>&1

ovirt installation guide | help setup

  1. follow download/install instructions from website
  2. create new local dir for storage via ssh, give permissions/owner to vdsm (36:36), go to the webadmin and "add storage domain" of type local with relevant path
  3. install the engine ssl cert from https:///ovirt-engine/services/pki-resource?resource=ca-certificate&format=X509-PEM-CA into your browser, otherwise the remote viewer won't connect, it will get "no route found" or "socket i/o" error.
  4. to get initial console connection you may need to "service iptables stop"

ovirt Backup Config Tips and Ticks!

https://github.com/fubralimited/ovirt-backup
install python 2.7
update the example config file URL to: server=https://centos7.local/ovirt-engine/api
remember to pass vm_list_example
./backup.py -c config_example.cfg -l vm_list_example

ovirt pci passthrough troubleshooting| device

dmesg | grep -iE "dmar|iommu"
[    0.000000] DMAR: IOMMU enabled
cat /proc/cpuinfo |grep -E "vmx|svm"
check for "vmx" hits

I never got it working.

how to mount manually, and auto mount dev mapper devices on centos | linux USB

fdisk -l | more
Disk /dev/sdb: 1000.2 GB, 1000204885504 bytes, 1953525167 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: gpt

#         Start          End    Size  Type            Name
1         2048    390627327  186.3G  Linux filesyste
2    390627328   1953525133  745.3G  Linux filesyste

Disk /dev/mapper/cl-home: 186.7 GB, 186692665344 bytes, 364634112 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/mapper/ST1000DM003-1E6162_Z1D3A8X1: 1000.2 GB, 1000204885504 bytes, 1953525167 sect
ors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: gpt

#         Start          End    Size  Type            Name
1         2048    390627327  186.3G  Linux filesyste
2    390627328   1953525133  745.3G  Linux filesyste
Disk /dev/mapper/ST1000DM003-1E6162_Z1D3A8X1p1: 200.0 GB, 200000143360 bytes, 390625280 secto
rs
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/mapper/ST1000DM003-1E6162_Z1D3A8X1p2: 800.2 GB, 800203676672 bytes, 1562897806 sect
ors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

testing manual mount, if works you can use those details for fstab auto mount after reboot.
mkdir /media/segateUSB_800GB
mkdir /media/segateUSB_200GB
mount /dev/mapper/ST1000DM003-1E6162_Z1D3A8X1p1 /media/segateUSB_200GB
mount /dev/mapper/ST1000DM003-1E6162_Z1D3A8X1p2 /media/segateUSB_800GB

so your mounting of dev mapper devices is working a treat, time to automate that shit.
vim /etc/fstab
/dev/mapper/ST1000DM003-1E6162_Z1D3A8X1p2       /media/segateUSB_800GB  auto    defaults        0 0
/dev/mapper/ST1000DM003-1E6162_Z1D3A8X1p1       /media/segateUSB_200GB  auto    defaults        0 0

reboot, test.